4

I've used Conga Composer for some time, but I've a new use case and issue that seems obvious but has me stumped.

Basically I want to include a Salesforce report but not have any dynamic filtering of any kind (i.e. not use the Master Object Id to filter). I simply want to include the report data 'as is'. The source in this case is Opportunities and I'm trying to create a merge report in excel that will include all Opportunities of a certain stage on one sheet and of a few different owners on other sheets.

This works fine if my source Salesforce report has no custom filters at all (so I know all the data is visible to Conga) - all the Opportunity data ends up on my output Excel workbook. But as soon as I add a filter to the Salesforce report, for example Stage="Final", then the report works as expected in Salesforce (only the matching rows are shown) but the Conga viewdata workbook says no rows are returned, and nothing appears in my output workbook.

I'm waiting to hear back from Conga support. In the meantime, am I missing something obvious? Why does adding a filter to a report work fine in Salesforce but makes a working report in Conga suddenly return no rows?

Is this a limitation of using Reports? (i.e. they need to use the Master Object Id or no filter at all)? Should I be using Conga Queries?

Thanks for your help Ray

1

I had this same problem when creating a link on a home page layout. The link uses Conga to generate a Word table of our active clients. Therefore, there is no "master record".

I actually included a master record id (the id parameter), just a random contact I picked, but did not pass any parameters to the report. When I opened the template builder, there were no rows visible in the report, even though it was clearly working in Salesforce.

I created a query instead, and this bypassed the problem. Probably the best solution, although, as a minor annoyance, you can't use the XMD parameter with queries, and so you have to include the query name in the template.

Another thought I had would be to just create a dummy parameter in the report, something like Name != xxxxxx, and pass a value from the master object into this. An ugly solution, but I think it would work.

I found their online documentation terrible, but their support staff have been prompt and helpful in the past.

  • Hi Matt, welcome to SFSE. Your answer is greatly appreciated, and indeed, you offer a solution. However, SFSE is more of a Q&A site, so please try to keep your answers as well as questions in the form. – Saariko Oct 10 '13 at 5:29
0

Heard back from support. If you have filters on the source report that you don't want to alter you still need to include the parameter in the URL but just pass an empty value.

e.g. My source report has one filter, "Stage = 'Final'", which I don't want to change. In the Conga URL calling this report I need to include pv0 (parameter 0) set to no value as follows:

https://www.appextremes.com/apps/Conga/Composer.aspx
?sessionId={!API.Session_ID}
&serverUrl={!API.Partner_Server_URL_80}
&id={!Conga_Report_Config__c.Id}
&ReportId=00OD0000005mGF7?pv0=

That got it working.

I should also mention I have another similar report with 2 filters. The first parameter I alter by passing a different value each time in the URL, the second stay's static similar to the above report. For some reason in this case, I only need to pass the parameter that's changing and it works fine. (I don't seem to have to do the empty parameter passing if there's second dynamic parameter involved)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.