0

I have a connected app with an outdated callback URL. I need a refresh token, so I updated the callback URL. Even after one hour the change is still not effective. When I call

https://login.salesforce.com/services/oauth2/authorize?response_type=code&client_id=<myclientid>&redirect_uri=https%3A%2F%2Fmy.newurl.com%2Fcallback

I get

error=redirect_uri_mismatch&error_description=redirect_uri%20must%20match%20configuration

as the response. When I use my old callback URL I'm redirected to the login page, but the callback times out, because there's no webserver reachable with the old URL.

I tried the same in a sandbox for the same instance and with https://test.salesforce.com/services... two days ago already, it also still hasn't applied the new callback URL setting. What am I missing?

0
0

You need to update the callback url in your app setup inside of salesforce.

setup -> create -> apps -> edit (your app)

Add your new Callback URL to the Callback URL whitelist then Save.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.