2

I created a managed package with a custom lightning component. After I installed this package in another org, I created a custom record page for Account object. I dragged the record detail component and the custom component into the custom page and activated it. It worked fine with the licensed user. But if a user is not licensed and the profile is System Administrator, it will throw an error which is "Unfortunately, there was a problem. Please try again. If the problem continues, bet in touch with your administrator with the error ID shown here and any other related details. ErrorID: 14292951943210(-1328812164)". But if the unlicensed user with any other profiles except System Administrator, then it is also worked.

I guess the error is because of the license, but don't know how can I catch this exception and don't know why only System Administrator did not work. Can anyone just explain how this license check works in lightning? Thanks.

  • I know this is an old issue, but Salesforce have finally admitted that this is a bug (after fighting with the clowns in support). success.salesforce.com/… – Xander Aug 8 '18 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.