1

I have a button on a Related List that is working fine in Classic, but while using within my Community, clicking the button does not invoke the Visualforce page. Are there any settings that I might have missed or any issues with this?

The button is on 'Items' as 'Edit Items'

enter image description here

enter image description here

6
  • are there any errors in the console? what about the network tab, can you include some debugging information? here is some useful information on debugging lightning developer.salesforce.com/docs/atlas.en-us.lightning.meta/…
    – glls
    Apr 27, 2017 at 22:11
  • Remember that Napili runs in Lightning so the VF page needs to be lightning enabled.
    – Dave Humm
    Apr 27, 2017 at 22:36
  • @glls - I enabled debug mode and installed the lighnting inspector. When i'm in the lightning tab and click this button, the only transaction that happens is (ltng:interaction) and that's it. Doesn't look like it is actually doing anything. If I do the same while in Lightning, I get the following evernote.com/shard/s2/sh/31af1bda-44d8-400a-a0f0-a5302bc6beea/…
    – csakon
    Apr 27, 2017 at 22:39
  • @DaveHumm I doubled checked this, it is
    – csakon
    Apr 27, 2017 at 22:42
  • I am getting same issue! @csakon did you get any workaround?
    – Ayub
    Aug 22, 2017 at 6:52

2 Answers 2

1

A likely cause is that the Visualforce page is not enabled for lightning and mobile. Napili and the other new templates run within lightning framework unlike the old Visualforce and tabs communities.

enter image description here

1

Visualforce list buttons are not supported in Communities.

https://help.salesforce.com/articleView?id=community_builder_use_visualforce.htm&type=0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .