4

I have some triggers which are showing compilation errors. These triggers are installed as part of a Salesforce managed package. How can I recompile those triggers or solve this error?

3
  • Welcome to SFSE! Are you getting any error messages explaining why they can't compile?
    – Mike Chale
    Sep 24 '13 at 11:56
  • my managed package trigger is on user object, when i am trying to update my user object,i am not getting the error continuously. i am getting the below error. error message :'first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, <triggerName>: execution of AfterUpdate caused by: line 19, column 10: Dependent class is invalid and needs recompil'
    – user3912
    Sep 24 '13 at 12:18
  • Please post the full error in your question. I assume the dependent class that is invalid is the one in the managed package? When you say "update my user object" do you mean add fields or change data on an existing user?
    – Mike Chale
    Sep 24 '13 at 12:29
6

Navigate to Setup->Develop->Apex Classes. There is a link near the top of the page called "Compile all Classes". According to the hover on the link it will compile your managed package classes.

Compiles all of your organization's Apex classes. Managed package classes can be compiled only by clicking this link. You must compile managed package classes before you can view them and run their test methods on the Apex Test Execution page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.