3

I'm trying to migrate new custom fields to a sandbox using the Salesforce Migration Tool (ANT). Two of the custom fields are picklist fields. And these two fields are causing the error: Error: Property 'picklist' not valid in version 39.0

  • Hope this helps. One suggestion, try using change sets. Just few clicks and nothing else, you'll be done. – Rohit Mourya Apr 14 '17 at 16:52
8

I think from 37 Api ver picklists are replaced with Valuesets in metadata definitions and it causes an error when You try to deploy 'old' metadata with higher Api Version. To get rid of this error, change your metadata file Api Version in Your package.xml file to 36.0 .

 <version>36.0</version>

Another option is to export objects from Your sandbox using connection with Api version 39.0, then the objects will have updated metadata definitions and You will be able to deploy them to new sandbox using 39.0 version API.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.