0

When we try to initiate new record creation action in lightning related list new button, this related list object have multiple record types so first we are getting redirected to Record Type selection page where we are selecting record type, next to this action on the record creation layout after filling all the data when we try to save this record we are running into below error.

Review the errors on this page.
Record Type ID: this ID value isn't valid for the user:

enter image description here

But this is working perfectly fine when we switch back to classic mode and try to create with same user, seems to be this is not a profile permission issue but something is wrong while the lightning page is trying to read the record type from record type selection page.

Is there any approach to come out of this error?

1

Even I faced this issue. Requirement : Redirect the page on new account depending on the record type.

Conclusion: Its working fine in SF Classic but in Lightning i'm getting the same error. The records are not capturing the selected record type. I tried sending the record type id in the url, but i guess the url hacking in disable in lightning.

Workaround : Might need to create a custom vf page of the information that need to be captured & insert in the record depending on the record type.

Hope this information might help you.

  • Thanks Ansari, this idea will help. But trying to figure out why this is behaving so strange in lightning. – rajasekhar Apr 24 '17 at 12:53
  • if you find out please do let me know as well rajasekhar. – Tabrez Ansari Apr 25 '17 at 10:11
0

It seems that the user does not have permission for the particular recordtype of that record.

  • 1
    Can you maybe expand on how the OP could verify/fix if this ends up being the issue? – Adrian Larson Apr 15 '17 at 15:14
  • Thanks, Mayank , But I don't think this is the issue with permissions because with the same user I am able to perform this action in classic mode so this is not because of permissions – rajasekhar Apr 17 '17 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.