0

I'm attempting to deploy a change set validated but I'm getting failures in my tests. I was very confused about this because I went at lengths to make sure all my tests passed in the Sandbox.

I have 2 processes that run built in Process Builder, one is the Diluent Update and the other is the Price Update. It turns out that in Production the Diluent Update process is running as expected.

However the Price Update doesn't get triggered. The Price Update process calls a Flow. This is the only thing I can imagine would cause it not to be fired during the validation.

Please note I'm NOT getting errors such as CANNOT_EXECUTE_FLOW_TRIGGER. The errors I'm getting are NullPointer exceptions from fields that should have been updated by this Process.

5
  • 2
    PB deploy as inactive. If tests rely on them you need to deploy separately and activate first
    – Eric
    Apr 12, 2017 at 14:25
  • I moved the PB stuff and activated them. Then tried moving the rest over. Now all tests are failing for not executing flow trigger
    – Josh D
    Apr 12, 2017 at 15:42
  • Thats overly broad and sounds like you have some issues either with your code or the PB. Looks like you have some work ahead of you..and possibly a series of new specific questions no.......
    – Eric
    Apr 12, 2017 at 15:43
  • My mistake! I activated the PB but there was a Flow called from one of the processes which I forgot to activate. Everything seems to be running now.
    – Josh D
    Apr 12, 2017 at 15:51
  • great, added as an answer then.....Was not sure it was the entirety of your problem initially
    – Eric
    Apr 12, 2017 at 15:56

1 Answer 1

1

PB deploy as inactive. If tests rely on them you need to deploy separately and activate first

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.