0

I'm using (the apparent latest because there's no updates ATM)

  • Eclipse Neon v4.6.3
  • Force.com IDE v38.0

When I run my Apex unit tests, I only get a green checkbox in a single item in the test results window, even when there are failing tests.

enter image description here

I do get the test coverage results.

Is this some sort of known bug or configuration issue?

7
  • What are your settings for download debug logs and for your individual logging settings for Apex Code, Workflow, etc? What you see would depend on those settings.
    – crmprogdev
    Apr 11, 2017 at 12:32
  • @crmprogdev where are those settings set? i think it worked in older versions... Apr 11, 2017 at 12:33
  • oh i found it @crmprogdev most everything is Debug. Some are info. i hadn't configured those. Apr 11, 2017 at 12:43
  • If that's the case, all you'll see are debug statements and Warnings.
    – crmprogdev
    Apr 11, 2017 at 12:46
  • @crmprogdev what should i set it to do get my test results? it seems a bit odd to adjust the tracing for a common dev tool Apr 11, 2017 at 12:48

1 Answer 1

0

I had similar situation couple of times. I don't know where is error, but I was helped by full synchronization of my IDE with my sandbox.

Right click on SRC folder in Eclipse -> Force.com -> Synchronize with server

We shouldn't have here any discrepancy between the environments. enter image description here

Sometime you can see that not exist any real differences between local file and server file, but SalesForce say you that they exist. It's a bug. You just do right click on the file/folder and choose the "Save to Server"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .