0

We have a custom activity that worked properly this Friday (2017-04-06). Today there's an error code in browser console that config.js is not found and gets a 404. When creating a new journey the custom activity doesn't launch and the error message

"One or more custom activities failed to load. Verify that custom activity endpoints are valid and refresh the Interaction."

appears. The endpoint URL has not changed since it worked. We also tried renaming the file where we host the app to config.js but still no luck.

I cannot get any information what config.js is supposed to contain, all documentation is about config.json. Does anyone have any suggestions on what to do?

2
  • 1
    I would bring this to SFMC Global Support and open an urgent case ASAP - as well bring it to your Rep's attention for escalation. This sounds like an internal issue from their service, not something that you would be able to solve. Apr 10 '17 at 14:15
  • I have added a case to global support but there has to be something from my side that has to change as well since SFMC runs a HTTP-get on config.js Apr 10 '17 at 14:17
0

To answer my own question: the error existed in the config.json file. For some reason the file contained a BOM after a commit in Visual Studio. After saving it as UTF-8 (without BOM) it started to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.