6

i got access to the Salesforce DX preview and I want to use the listed commands in order to make some testing, after been looking for a way to use it I don't really see something that says how to install it.

What basically want to do is to create an scratch org using this command:

 heroku force:org:create -f config/workspace-scratch-def.json

Once I got access what should be the next steps in order to use the commands? I would like use the sample described here

  • 4
    You should login into chatter group with your partnerforce (?) account, based on which your beta has been requested, There you can find instructions how to install the tool. – kurunve Apr 3 '17 at 11:48
  • Pilot or Preview features that are closed should not be asked on SFSE. Instead these questions should be directed to the product team who normally have an avenue of support for anyone in the pilot or preview program. Also, the chances of the same problem happening once generally available is quite small, meaning this question is unlikely to benefit people after the fact. – pchittum May 11 '17 at 19:26
2

Here's the link for download SFDX:

https://developer.salesforce.com/tools/sfdxcli

| improve this answer | |
2

Adding to Steve's answer, the complete process on Windows is to:

  1. Search for 'Advanced system settings' and click on 'Environment Variables'
  2. Under 'System variables' click on Path
  3. Press edit then 'New'
  4. Write C:\Program Files\Salesforce CLI\bin and press OK

This issue seems to arise regardless of whether you asked sfdx to add itself to your PATH while installing.

| improve this answer | |
1

I assume you have installed SFDX from the link provided by Peter. If the problem still comes then it could be because you've forgotten to add the Path to System Environment Variable.

If not, copy the Path "C:\Program Files\sfdx\bin" and paste it into System Environment Variable. This might solve your issue.

| improve this answer | |
0

Environment Variables in Windows has two sections, one for the User and one for the System.

In my case, the Salesforce CLI tools was installed using an Administrator account and the installer had updated the User path but not the System path.

I had to manually update the Path entry in System Variables with the following path:

C:\Program Files\Salesforce CLI\bin

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.