14

I'm working on the development of some Lightning Component Quick Actions and I need to test some responsive behavior on Salesforce1. I'm running into a lot of caching issues and am having to reset the entire application every time I make a change to my component. Even then, sometimes I get an obsolete version.

I've taken a look at this question and set my Session Settings accordingly. This doesn't seem to have any effect in SF1. Is there something else I can change in the settings somewhere to prevent this caching issue in SF1?

  • 1
    Didn't see this mentioned in the other question you linked to but have you tried disabling the offline cache for the entire org to see if that helps? Setup --> Salesforce1 Offline --> Uncheck Offline Cache – Brand0R Apr 7 '17 at 15:18
  • I am on the same boat and still occurs. Have you figured this out yet? – Lightning Evangelist Jul 24 '18 at 20:31
1

If you're using the Chrome, Opera, or Firefox browser, you can disable caching by bringing up the context menu, choose Inspect (Inspect Element in Firefox) to bring up the dev tool, go to the network tab, and check Disable Cache. The dev tool menu must remain open in order for this to continue working.

enter image description here

-2

Go to SETUP --> Salesforce1 Offline --> Uncheck all chechbox of Salesforce1 Offline. enter image description here

-2

Have you tried this?

Clear app cache in Salesforce1 for iOS

  1. In Salesforce1, tap the Menu icon | select Settings
  2. Tap Advanced
  3. Tap Clear Cached Data
  4. Restart Salesforce1 and check for your changes

Clear app cache in Salesforce1 for Android

  1. In Android, open the Android Settings app
  2. From the list of settings, tap Applications
  3. Tap Application Manager
  4. Tap Salesforce1
  5. Tap on Storage and the buttons for clearing the cache and app data will become available
  6. Tap Clear Cache
  7. Restart Salesforce1 and check for your changes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.