0

This is very weird. I've been testing the whole day and I don't get what happened. I have a DE with some display names and links. I retrieve them perfectly in my email, but if I write the link in the href attribute, this is changed for another URL, but otherwise if I write it in any other place, it's OK!

Any reason why? How do I fix it?

enter image description here

enter image description here

1

I believe the issue is click tracking is being added to the links you hardcode into the email, but the ones that you put in via the variable in AMPScript are not included inside of the sweep that SFMC does prior to each send. This has been a bug that has existed for a couple years now inside of SFMC.

Both links should end up at the same place, just the one that has click tracking forces a redirect from another page first.

To prevent click tracking, you can remove the check from this box (Track Clicks) when you send the email (via wizard, user initiated send or trigger send) inside the 'Configure Delivery' section.

To have your links tracked when inserted as a variable, you should utilize Redirectto() or TreatAsContent() function calls.

Sample question on issue

Article about the issue

| improve this answer | |
  • Thank you for your help, I've been testing your suggestions. I've tried both. Redirectto() and TreatAsContent(). With the Redirectto, apparently I don´t track any click events on my email..... and with the TreatAsContent(), I'm not able to do it a link. :( – manukadi Mar 29 '17 at 13:59
  • Thank you Adam, but I´m a little bit lost about those content areas... I have a DE with id displayName, and URL. and depending what the subscriber has choosen, I show him the links..... and I want to track the links..... when I wrote the URL directly in the href, I got some "clicks events" FROM _Click, but when I use Redirectto(). I can't get any information. Thank you in advanced :) – manukadi Mar 29 '17 at 14:18
  • Using Redirectto() inside of your href attribute does work - I just tested your exact code above using a dummy URL and it correctly applied click tracking. The send preview will not display the click tracking link, you will need to do a test send to see it. – Gortonington Mar 29 '17 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.