0

Using SOSL I did the following Query:

FIND {name} in NAME FIELDS Returning KnowledgeableUser(ID)

Console returns the following:

entity type KnowledgeableUser does not support search

It looks like this Object is not query-able, is there any way to change this as the object is not available from the setup menu since i think it is set by default to searchable=false ?

tried open execute anonymous windows as well:

List> searchList = [FIND 'name' in NAME FIELDS Returning KnowledgeableUser(ID)]

enter image description here

  • 1
    Did you also try querying in Execute Anonymous Window, i remember some SOSL queries are not supported by Developer console – Raul Mar 24 '17 at 15:08
  • yes i did, same result – glls Mar 24 '17 at 15:18
  • You are filtering on single field, why not use SOQL? – Raul Mar 24 '17 at 15:56
  • in the example i provided, yes, i only search for one single object and field, however, my use case involves text search on multiple objects and fields – glls Mar 24 '17 at 16:22
  • 1
    Yes, if you take a look at the Standard Objects, for Knowledgeableuserthere are three option : describeSObjects(), query(), retrieve() .... there is not search(). developer.salesforce.com/docs/atlas.en-us.api.meta/api/… – Carlos Naranjo Mar 25 '17 at 19:34
1

If you take a look at the Standard Objects, for Knowledgeableuser there are three options : describeSObjects(), query(), retrieve() .

There is not search() method available.

Link to SFDC Documentation

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.