1

I have a managed VF page that is displaying the above error when an action link is clicked -only in a particular subscriber sandbox (it has been working fine in every other org). The link sets a variable in the controller (call it selection) and re-renders a panel whose content is shown when selection is set. This panel should display a few things that were fetched via getter methods. Instead the page suddenly is going blank with this error message:

Unable to Access Page

The value of the "" parameter contains a character that is not allowed or the value exceeds the maximum allowed length. Remove the character from the parameter value or reduce the value length and resubmit.

I don't want to get into the code here as I am just trying to see why the parameter in this message is resolving to blank. The Debug Logs are not showing anything at all even with logging levels set to Finest.

I have done my research and seen other similar posts on SFSE, but my issue is with the blank parameter. I am hoping that with this knowledge I can figure out the next step.

  • Where does the value of the parameter come from? Maybe there is a hidden character code (usually from a copy and paste operation) in the data the parameter is derived from. You should be able to login to the customer org via the LMA and do some string tests and troubleshooting via dev console using the code snippets from your controller – Eric Mar 23 '17 at 22:42
  • @Eric This is a restricted org and LMA doesn't work in there. The value of the parameter is statically set within the page via apex:param. I am suspecting that the error message is a red-herring and the data that is returned by the controller (that is to be displayed inside the panel) has some sort of incompatibility. I am currently playing trial and error; 21st century debugging at work.. – Mossi Mar 23 '17 at 22:50
  • ouch, hopefully someone who has run into this exact situation will come along. That may be your only hope to get an answer here. If you do figure it out please do post an answer....... – Eric Mar 23 '17 at 23:17
  • Any clues in the browsers developer console? Something like the Network tab that Chrome has. This show show the data that is being sent back to Salesforce can causes the error. – Daniel Ballinger Mar 24 '17 at 0:43
  • @DanielBallinger I have inspected the Chrome Console already with no leads other than the AJAX call to the server apparently going through ok. – Mossi Mar 24 '17 at 4:15
2

Turned out Apex was throwing this exception:

System.InvalidParameterValueException: Custom Setting Name too long: ...

with the offending line being:

MySetting__c.getValues(veryLongValue);

This was part of a getter method that was supposed to return a list of SelectOptions.

I still don't understand why this was causing the page to break with such misleading message. I experimented with a few other exception types -including null pointers as well as custom exceptions- and they all displayed appropriate messages on the page.

1

I received a similar error although a Vf page was not involved; it was thrown when we tried to edit Page Layouts (in Lightning and Classic). In our case it was a lookup field on Messaging User to Lead that threw the same error. We had to delete the lookup field to restore the ability to edit Layouts.

Thought I would put this response here in case others end up on this question after receiving the error to help them troubleshoot possible causes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.