2

Got a problem: in our organization we have 1 production and 1 full sandbox. In both we have a same application with same version. Today users started to complain that they couldn't get access to one of the reports that is included to managed package. Tried to find the report in production through workbench including deleted items, also checked recycling bin - was not able to find the report. Meanwhile in sandbox the report's on the place, I see it in my "reports" tab. The applicaiton in prod and sandbox has same last modified date, which's almost half a year ago. Clicking "View Components" in production, I don't see the report, while doing the same in sandbox, I see the report. Also tried to copy Id from SB and paste it to production - see the error "Data Not Available".

Question is - how it could be, that managed package report is not visible (or deleted) in production, but visible in sandbox?

Added:

Sandbox package: Sandbox package

Production package: Production package

  • 1
    Is it the same version of the Managed Package? – Phil Hawthorn Mar 20 '17 at 18:33
  • @PhilHawthorn, yep, absolutely. – EvAzi Mar 20 '17 at 18:37
  • 1
    Found this in documentation "Reports are dropped from packages if they have been moved to a private folder or to the Unfiled Public Reports folder." Also check setup audit trail. – Raul Mar 20 '17 at 19:02
  • Thank you, @RahulSharma! Is it possible to understand in what private folder is it? Tried to query the report via workbench by report Id - no success. – EvAzi Mar 20 '17 at 19:04
  • 1
    It was just a guess. Workbench should work. Not sure if packaged reports can be deleted. Try looking at setup audit trial to check who moved or deleted the report? – Raul Mar 20 '17 at 19:13
1

The problem was in that a person moved the report to his private folder, thanks to Rahul Sharma for pointing out to this document. You could find in what folder it is stored following the link. The report will have different Id and will no longer be marked as a part of managed package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.