3

I have created a CloudPage with a Smart Capture form that writes to a data extension, form renders with no problems, but on submission of the data, Google Chrome console shows a 500 server error, no errors are shown in ExactTarget. Pretty new to this platform so please let me know if you need any further information.

CloudPage can be found at https://pub.s7.exacttarget.com/afw1r5bkbte

This page was built using the new Content Builder within ExactTarget.

  • 1
    Please add the JSON-Response of the request that returns the HTTP 500 error. Sometimes there is additional information which helps debugging the issue. – Markus Slabina Mar 17 '17 at 12:05
  • Thanks @MarkusSlabina, where would I find this JSON response? The page was built using the Content Builder within SalesForce – terrorfall Mar 17 '17 at 12:10
  • 1
    In the Google Chrome developer tools under "Network" you should see the failed route and clicking on it will show details. The exact response can be found with a further click on "Response". For this to work, you need to open the developer tools before submitting the form. – Markus Slabina Mar 17 '17 at 12:13
  • Response view only has the HTML of the 500 error page. The only JSON I have is in the request data – terrorfall Mar 17 '17 at 12:41
  • 1
    What fields comprise the primary key on the target DE? What about the field data types and precisions? Are they appropriate for your inputs? – Adam Spriggs Mar 17 '17 at 13:59
2

I'd bet that you're violating the primary key or that your inputs don't match the data types and precisions configured in your Data Extension.

| improve this answer | |
  • 1
    omg the error feedback is so terrible, spend multiple hour, finding out i had af bool field, but wrote a string into it – Bidstrup May 22 '19 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.