0

From a very random moment onward, the three Javascript buttons in Salesforce do not work anymore.

They were installed with the Marketing Cloud package. They're the "ExactTarget Unsubscribe" ; "ExactTarget ReSubscribe" and "Send ExactTarget Email" buttons on Account/Contact record.

The Javascript alert will state:

faultcode:'soapenv:Client', faultstring:No service available for class 'jsButtonMethods"

Does anyone have any ideas?

  • 1
    Are you able to move the Marketing Cloud tab in Salesforce and verify the configuration? what version on the Marketing Cloud Connector are you using? – David Devoy Mar 9 '17 at 21:26
  • Hi atheri - did we manage to solve your question? If yes, please select a best reply :) – Kenneth Wagner Jun 15 '17 at 8:00
1

I believe this is due to the retirement of Javascript button functionality. It sounds like you are using an older version of the connector?

In my recent install, the MC Connect has no buttons but rather custom links instead - and they're named marketing cloud, not exacttarget.

If you can, then upgrading the connector is the right option. Alternatively, you should be able to wrap the JS in lightning, believe there is a help article on what you should do with old JS buttons, but not my strong suit.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.