8

Using the Force.com Migration Tool (Ant) v1.9.4 to deploy from one sandbox to another both on Spring '17 results in

21.  profiles/Admin.profile -- Error: Unknown user permission: ManageSandboxes
22.  profiles/Finance.profile -- Error: Unknown user permission: ManageTranslation
23.  profiles/Admin.profile -- Error: Unknown user permission: SocialInsightsLogoAdmin
etc.

If the orgs are on the same release, how is the target returning an error here? I'm guessing there are manual settings that are different from org-to-org?

This is such a common error it makes using the Ant tool frustrating

4 Answers 4

5

My source and target environment were on the same version so to solve similar issue I clicked "Match Production Licenses" on source and target. Please verify.

2
  • If you’re using CI, this could be a common solution to avoid manual steps. Commented Aug 25, 2018 at 15:36
  • hello i have tried this and i clicked from both source and target org but still got the same error - Error: Unknown user permission: ManageSandboxes , any solution please Commented Apr 22, 2020 at 11:34
2

There are permissions that vary from org to org, either because of permissions provided by Salesforce, or features that can be enabled by an administrator. If a particular feature is not enabled, the related profile permissions will also not exist, which will cause errors like this. For example, deploying a profile to a sandbox, you'll notice that ManageSandboxes does not exist, because Sandboxes cannot create other Sandboxes. Similarly, if Translation Workbench is not enabled in an org, the ManageTranslations permission will not exist. Make sure that the destination org has the same licenses and features as the source organization, or you will need to manually edit your profile files to remove the missing permissions.

3
  • Can you elaborate why ManageSandboxes in not available under UserPermissions. For me, ManageSandboxes in not available in Full Sandbox, but it is available in Partial Sandbox. Commented Aug 11, 2020 at 8:13
  • @IsuruBuddhikaHerath I'm not sure. That sounds like a glitch. When I wrote this answer, you couldn't access the Sandbox menu at all in a sandbox, so the permission also didn't exist (or I was mistaken?). Have you tried contacting Support?
    – sfdcfox
    Commented Aug 11, 2020 at 14:33
  • If you search on setup, you cannot find the sandboxes menu. That is correct. But in my case, when I go to, Setup -> Profiles -> System Administrator -> System Permissions. The ManageSandboxes permission was not availble under the Users section at the bottom of the page. Any way I was able to fix this pressing Setup -> Company Information -> Match Production Lcienses. Commented Aug 13, 2020 at 2:38
2

Unknown user permission errors are because you have not activated a feature in the target org.

When you activate a different features, Salesforce creates new settings/options.

ManageSandboxes is a setting in production, matching licenses should fix this issue.

ManageTranslation - you have to activate Transaltions in the target org. Setup > transaltions > Enable

SocialInsightsLogoAdmin - not sure, but im assuming its something with a feature called Social Insights.

0

The "unknown user permission" type errors are either because of-

  • The version indicated in the package.xml doesn't support the feature, or
  • The source environment is on a newer API version than the target, and it's supported in the former and not the latter, which is not valid in your case.

So I guess it is because of the version in your package.xml

Try to make sure your source and target environment will be on the same version whenever you plan to deploy.

If this is no longer possible, you can also manually remove the reference to that specific profile permission before deploying.

1
  • These are the boilerplate answers for sure. Both orgs are Spring '17 and I'm using v.39 so I'm baffled as to why I have to manually edit in this instance. I've been unable to find docs on which permissions API v.39 supports although I sure thought it was after these features were released. Commented Mar 13, 2017 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .