0

I have set up an html email template and noticed several field's value is not populated. I have done SOQL query on those records and the value for those fields are good. And I have set the field level security for that particular field visible to everyone. The email template line looks like this:

DFV Request: {!Ida_Hearing__c.Domestic_and_Family_Violence_Matter_Text__c}

And the field is a formula field whose field looks like below:

IF(Domestic_and_Family_Violence_Matter__c , 'Yes', 'No')

It doesn't seem to me there is any cross object reference in this email template. What can be the reason why it is not displaying?

  • Did you try to check the "Send Test and verify merge field" option on email template? Did it work there? – Salesforcesmarty Mar 6 '17 at 0:08
  • @Salesforcesmarty No, it doesn't. It is still in development and testing phase so when I see I didn't see the field value populated I have actually meant the email I received from that button. – Lance Shi Mar 6 '17 at 0:10
0

Just figured out.

It seems that even if I spelled everything perfectly right, the email template might still not work. Should always use Merge Field button instead. Then everything works smoothly for me.

But I am not quite sure whether this is a bug?

  • I will also verify this at my end. Hope this is not a bug. – Salesforcesmarty Mar 6 '17 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.