1

I have a address object where Account is the master object. Sharing setting said address is controlled by parent . Account is private . My requiremnt is all user can create and update address. So I have turned on tab address for all profiles and gave obj permission read/create/edit . But after deploying to QA sandbox, when I log in as any user I dont find my address tab to create address as user. I thought app does not have tab added, so I added address tab for that app. but still I cant see the tab as any user. Could anybody help what I am doing wrong here or any solution please. enter image description here

4
  • check the profile, if the tab is default off or hidden. Commented Mar 5, 2017 at 6:33
  • You can't give read/create/edit permissions to a detail object. Did you modify the parent object permissions? Is the tab visible to the user
    – Eric
    Commented Mar 5, 2017 at 7:00
  • @SantanuBoral Tab default is on.
    – maruf
    Commented Mar 5, 2017 at 17:46
  • @Eric Parent object has read/create/edit permission already. Tab is visible.
    – maruf
    Commented Mar 5, 2017 at 17:46

1 Answer 1

2

The problem you're having is that even though the profile's tab setting is "Default On," you have not overridden the users' current settings in the apps. New users assigned to that app would see the tab automatically, but existing users need to have their settings updated. To do this, edit the app you placed the tab in (Setup > Create > Apps), and immediately below the multi-select list for the tabs, you'll see an option that reads "Overwrite Users' Personal Custom App Customizations." You need to check this box in order to reset the tabs for all users.

6
  • thanks for the reply. I have two sandbox. Whatever I work on first sandbox, I have to deploy to next sandbox name QA sandbox. In first sandbox, I can see the address tab as any user even overridden the users' current settings is not checked. But when I deploy app adding that address tab from first sandbox, In QA sandbox I don't see that address tab when I log in as any user except system admin. Is it the reason that I did not checked overridden the users' current settings in the app before I deploy the app to QA sandbox?
    – maruf
    Commented Mar 5, 2017 at 18:04
  • @maruf The "override" checkbox is a one-shot feature. It doesn't stay checked. You have to do the override option once to update all user preferences.
    – sfdcfox
    Commented Mar 5, 2017 at 18:11
  • Thanks again. If all user need to see that address tab, then should I Overwrite Users' Personal Custom App Customization check and then deploy from 1 sandbox to another sandbox or should I check override from each profile ?
    – maruf
    Commented Mar 5, 2017 at 18:15
  • @maruf First, deploy with the tab, app, and profiles selected, as this will set all the appropriate permissions. Then, go in to the app after deployment and use the override checkbox.
    – sfdcfox
    Commented Mar 5, 2017 at 18:29
  • Thank you. I tried to deploy with app but I did not see that particular app there, so I deployed tab and profiles. after deploying to QA I see that whatever changes I did in profile for object level permission in 1st sandbox, those changes did not reflect on QA sandbox for profile. Is there any particular reason for that ?
    – maruf
    Commented Mar 5, 2017 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .