1

I'm using eclipse and trying to update class xml file to status 'Deleted' in order to delete it from production. But anytime I'm trying to save I get below error message "Unexpected error has occur", and the change being saved only locally.

Any idea what could cause this issue? Does eclipse save somewhere logs with more details regarding the error?

Note: It happen when any class/trigger and with any sandbox. The class it not being reference anywhere, to verify this I created dummy new class and got the same error when trying to delete it.

enter image description here

  • I think you can save the file locally in sandbox and deploy it to production. – Raul Mar 4 '17 at 16:53
  • Try changing the API version to 37 or above. – Mahmood Mar 4 '17 at 17:15
  • @Rahul sharma this is an accepted approach to delete classes/triggers from production. – Mahmood Mar 4 '17 at 17:17
  • comments: Indeed I can deploy it for deletion by only saving locally. Still trying to know what causing this error. @Mahmood I tried using different API versions and all giving the same behavior. It seems more likely related to the eclipse, although I didn't update it recently. I'll try to delete and download new eclipse version – Liron C Mar 4 '17 at 17:28
  • Older eclipse version can be buggy sometimes. – Raul Mar 4 '17 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.