1

I have a managed package with the following class already in it:

global class MyInterfaceClass
{
    global interface InnerInterface {}
    global interface DeepInterface extends InnerInterface {}
}

When I edit this class without making any changes and save it I get the error in the subject line. The error is pointing to line 4 where the extension is defined.

Has anyone else come across this anomaly? Any suggestions on how to solve it? I have tried editing in Developer Console as well as the web editor both with same outcomes.

  • Sounds a bit like a bug for a very specific way of setting two interfaces. You would probably find if InnerInterface wasn't defined in the same class as DeepInterface it would be fine. There might be some validation mix up that makes it look like the base interface is changing, even though it isn't. – Daniel Ballinger Mar 2 '17 at 6:48
  • FWIW I have the same error message with a class that has been released for ages, and modified multiple times since initial release without problems. It doesn't have the same nested interface structure though: it simply implements a bunch of interfaces (Database.Batchable<sObject>, Database.AllowsCallouts and Database.Stateful) – Jelle van Geuns Jun 10 '17 at 4:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.