0

I have two tabs on an inline page. When the page is rendered the data is showing correctly for first tab. When I click on second tab the data doesn't show correctly. It looks like the page isn't getting the correct contact id. When I click on first tab again, it shows correct data again.

When I test the inline page separately it shows correct data for both tabs. So there is nothing wrong with the code or logic to bring the data. Only if it is included as inline page in another page, the second tab is not showing the correct data. Am I missing something here?

I have put system.debug statements at several places in controller used for the page. These are showing up in the debug log when the first tab is clicked, but these are not showing up when second tab is clicked.

Minerals is the inline page which has two tabs. Here is my code:

 <apex:pageBlock id="PBMin" rendered="{!isViewMode}">        
        <apex:pageBlockSection title="{!$Label.Minerals}" columns="1" rendered="{!isViewMode}">
            <apex:include id="Minid" pageName="Minerals"/>
        </apex:pageBlockSection> 
</apex:pageBlock>
  • So you have a page with data that is not showing the correct data and all you provide the community with the the door? No-one can tell you whats wrong with your house if thats all you show us..... How to Ask – Eric Mar 1 '17 at 15:44
  • I posted expecting somebody can give general idea not the exact fix. I have several hundreds lines of code. I don't know if I can post whole code. Also it has client specific details. – SFDC Mar 1 '17 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.