2

I am trying to create a new managed package from my dev org. I am following the steps in the documentation - https://developer.salesforce.com/docs/atlas.en-us.packagingGuide.meta/packagingGuide/packaging_uploading.htm . In the doc I see I have to go to setup->Package->Create new package. I am unable to select the managed checkbox option which is disabled. How can I enable it? I do not have any other package available nor I have created a namespace. This is a fresh developer org where I moved the code from another env.

enter image description here

2 Answers 2

3

You actually need a namespace for a managed package.

The "Managed Packages in More Detail" section of this help guide has more details on what is required.

3
  • Doesn't the doc say to create a managed package first? and then use namespaces etc
    – SfdcBat
    Commented Mar 1, 2017 at 1:08
  • 1
    It's phrased poorly. You need a namespace first and then you create your package. Commented Mar 1, 2017 at 1:14
  • 1
    +1 John, you beat it to me. Unfortunately while typing from mobile it doesn't notify about an answer.
    – Raul
    Commented Mar 1, 2017 at 1:24
1

You have to register for a namespace as mentioned in document itself that its a prerequisite.

Before creating a managed package:

Configure your developer settings

2
  • Are you saying the managed checkbox will be enabled only after I register the namespace? Do I need start creating the package meaning adding the components only after namespace is saved ?
    – SfdcBat
    Commented Mar 1, 2017 at 1:21
  • Yes, that's correct!
    – Raul
    Commented Mar 1, 2017 at 1:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .