I'm finding no helpful information on this.

When an error mentions a 301-prefixed Id, I know it's Flow related (probably Process Builder), but I have no clue how to hack a URL to showing me the Flow (or Process Builder) in question. Typical http-salesforceDOTcom/ID references do not work.

I have no clue how to debug such errors without the ability to know WHAT Flow / Process Builder routine it means. :-(

In the screenshot, 301* is the "Flow", while a5A is a managed Custom object (Customer Master from Rootstock). I can't simply put the 301* reference after a Salesforce URL like most objects.

Error Message

Insufficient Privileges You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.

UPDATE 1:   This is the closest I came to a solution - someone mentioning the same concern in an Idea: https://success.salesforce.com/ideaView?id=08730000000DmI7AAK - a year ago.

3 Answers 3


The URL format for going to a Flow is:


INSTANCE is your Org instance (na9, cs26, etc)

VERSIONID is the version of the Flow referenced in the error message (301*).

  • 1
    Visual flow and Process builder flows are internally stored in same object(Flow) that is why both have same prefix (301*). The above approach will open even a process builder flow in Visualflow editor. To determine whether the flow is a Visualflow vs Processbuilder flow, use this query in tooling api : SELECT ProcessType FROM Flow WHERE Id='301***'
    – javanoob
    Feb 28, 2017 at 13:53
  • 1
    "Flow" in above query is not a valid object name. Apr 13, 2018 at 17:11

Ran into same issue like this in the past for a client who used process builder heavily and it was time consuming to locate the offending flow version.

Here are two approaches:

Appraoch #1 (Using Tooling API):

Check the checkbox Use Tooling API in developer console and run the below query:

FROM    FlowDefinition


enter image description here

NOTE: You can finetune this query further by referring to the Tooling API reference.

Approach #2:(Using chrome debugger)

  1. Enable chrome debugger and navigate to the network tab.
  2. Click on all the versions to open the process builder designer and you should see the versionId of the flow in the network tab as shown in the below screenshot.

enter image description here

Others may have a easy method to locate the version by the Id showing in the error message but this is what I used to debug the failing version.

  • Chrome approach worked. Thanks. Apparently I've never tried querying in DevConsole, as the results were completely different layout/etc than your screenshot. Oh well.
    – AMM
    Feb 27, 2017 at 18:31

Goto Workbench > Utilities > REST Explorer > Make a GET call with this path (/services/data/v37.0/tooling/sobjects/flow/{flowID})


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.