0

I've just applied my app and received this:

Dear developer,

We have discovered one or more issues with your recent delivery for "xxx". To process your delivery, the following issues must be corrected:

Invalid Bundle Structure - The binary file 'xxx.app/JB4A-SDK/libJB4ASDK-4.7.0.020600001.a' is not permitted. Your app can’t contain standalone executables or libraries, other than the CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide for information on the iOS app bundle structure.

Once these issues have been corrected, you can then redeliver the corrected binary.

Regards,

The App Store team

Does anyone know why?

  • 1
    Is your target an Extension? – shallowThought Feb 24 '17 at 10:14
  • sorry, what's target? I'm developing an iOS app – Jared Chu Feb 24 '17 at 10:26
2

The JB4A-SDK/libJB4ASDK-4.7.0.020600001.a static library is copied to the App Bundle. Don't do this.

  • Add it to the target's Link Binary with Libraries build phase.

  • Do not add it to the target's Copy Bundle Resources build phase.

  • Add it to the target's Link Binary with Libraries build phase But it's in the instruction of SalesForce: salesforce-marketingcloud.github.io/JB4A-SDK-iOS/… – Jared Chu Feb 26 '17 at 15:33
  • Afaics, it says: "Add libJB4ASDK-*.a to Linked Frameworks and Libraries in the Build Phases configuration...", like I wrote in my answer. Please explain. – shallowThought Feb 27 '17 at 11:19
  • hmm after I moved it out of project structure, the issue has gone. thank you – Jared Chu Feb 27 '17 at 12:57
  • 1
    Makes sense. Your app bundle must not contain an executable other than the app itself. Having the .a (executable) file in your project (added to your target) triggers the warning. Happy coding. – shallowThought Feb 27 '17 at 21:47
2

Jared, can you confirm that the static library is NOT included in the "Embedded Binaries" section of your target's General settings pane in Xcode? That would appear to trigger the error you have.

Also, in the Build Phases pane, verify that there is no copy phase for the static library.

Thank you,

Brian

  • after I moved it out of project structure, the issue has gone. thank you – Jared Chu Feb 27 '17 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.