0

I have created a data extension on marketing cloud that contains a field (Relationship Type) that references a multiselect picklist from Salesforce. The query works great with the other fields. I don't get an error when I run the query but the Relationship Type field is empty.

I have set the relationship type field on the data extension as text with a length of 255.

The query is as follows:

SELECT
  cs.Id AS SubscriberKey,
  cs.Firstname AS FirstName,
  cs.Lastname AS LastName,
  cs.Email AS Email,
  cs.MailingCountry AS Country,
  cs.SLH_Region__c AS Region,
  cs.Relationship_Type__c AS 'Relationship Type',
  cs.Primary_Contact__c AS 'Primary Contact',
  acc.Name AS AccountName
FROM 
  Contact_Salesforce AS cs
INNER JOIN
  Account_Salesforce AS acc
  ON cs.AccountId = acc.Id
INNER JOIN RecordType_Salesforce AS rts ON (
  rts.Id = cs.RecordTypeId
  AND rts.name = 'Hotel Member'
)
WHERE 
  cs.Active__c = 1
AND
  acc.Current_Status__c IS NOT NULL 

Thanks!

  • Can you confirm if the Relationship_Type__c field in your Contact_Salesforce DE actually contains (semicolon delimited) picklist values, or are the values empty for all records? – Eliot Harper Feb 21 '17 at 21:27
  • Have you tried to make the field on the data extension nullable? – Samuel Dare Feb 22 '17 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.