6

I observed a strange behaviour that I don't find in documentation or, is the first time that i get out this behaviour.

I created a simple formula field on user, Profile_name__c (formula field of type string with formula = profile.name)

the strange behaviour is that I get different values depending on whether I access the formula field by api, or by standard salesforce interface (GUI).

Using the standard user interface I get the field set to "System Administrator". When I access the field via APEX or workbench I get as value "PT1".

I don't understand if is an issue, or some new behaviour introduced by Salesoforce with the last release. I'm missing something...

Can someone give me a hint, to understand if is an issue or a standard behaviour?

  • Please share the formula you have used. – Adrian Larson Feb 20 '17 at 16:19
  • sorry, i thought was clear, i tried to explain here: Profile_name__c (formula field of type string with formula = profile.name) – Klodj_Meta Feb 20 '17 at 16:22
9

This is a Known Issue that has not been resolved. Please log in with your Success credentials (probably your production or developer edition login) and check "This issue affects me" to be notified of resolution.

One current workaround would be to do this:

CASE(Profile.Name, 
     "PT1", "Read Only",
     "PT2", "Standard User",
     ...
     Profile.Name)

The list of known PT# codes are documented here.

| improve this answer | |
  • thnks, I was not able to get out it from google. Thanks for the tempestive feedback, i reported it. – Klodj_Meta Feb 20 '17 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.