good old message is the following :

Organization Administration Locked The changes you requested require salesforce.com to temporarily lock your organization's administration setup. However, the administration setup has already been locked by another change. Please wait for the previous action to finish, then try again later.

I tried everything described in Organization Administration Locked...?

  • There is no current deployment: enter image description here

  • This is no current Unit Test enter image description here

  • Click on dev console "cancel all deployments" enter image description here

  • Create/delete/switch workspaces: unsuccessful

  • Is there a way (script ? setup menu?) to know WHICH current lock is blocking us ?

  • 2
    You can check the "Setup Audit Trail" to view recent actions that may be preventing you from further changes. – TSmith Feb 17 '17 at 13:00

Try the following:

  • Open an existing class in the Developer Console
  • Go to File and click Save (even without changes)

Else you can try to save the class with the Metadata API instead of the Tooling API in a tool like the Force.com IDE or MavensMate

There's a known issue with this, but a colleague of mine fixed it with the above steps. https://success.salesforce.com/issues_view?id=a1p3A000000E1YYQA0

  • Also not working from Force.com IDE :/ There is something locking but no way to fidn what, and this lasts since nearly 4 hours now ... we are 5 devs to be stucked because of that :/ – Nicolas Vuillamy Feb 17 '17 at 13:11
  • And you used the Metadata API with the IDE? – Folkert Feb 17 '17 at 13:28
  • Yes, as Force.Com default settings use Metadata API – Nicolas Vuillamy Feb 17 '17 at 13:48
  • Tryin with Tooling API didn't help either :/ – Nicolas Vuillamy Feb 17 '17 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.