6

The following code used to work perfectly from CRM & from communities

<ltng:require styles="{!join(',',
        $Resource.bootstrap + '/bootstrap-3.3.6-dist/css/bootstrap.css',
        $Resource.resource +'/resource/css/irm-style.css' ,
        $Resource.resource +'/resource/css/irm-style-new.css'
    )}"
    scripts="{!join(',',
        $Resource.jquery,
        $Resource.momentJS
    )}" />

But since Spring 17 upgrade, rewrited URL doubles the name of the community :

ex: GET https://xxxxxxxx-developer-edition.eu11.force.com/distributor/distributor/resource/1486435172000/bootstrap/bootstrap-3.3.6-dist/css/bootstrap.css

distributor is the name of the community, and is strangely written twice in the URL generated from $Resource

Is my code wrong / not supported anymore ?

  • 1
    I have the same issue in my sandboxes since Wednesday. Since today I also have the issue in production. I contacted Premier Support, but so far I haven't received a solution. – svenf Feb 17 '17 at 12:25
  • 1
    I solved it temporary replacing $Resource.resname by '/resource/resname' , but I have it in lots of places so i'd prefer SFDC to publish a fix than if we have to update all our code ^^ – Nicolas Vuillamy Feb 17 '17 at 12:38
  • I have the same issue, and same temporary fix. – Fabien Taillon Feb 20 '17 at 15:36
4

Salesforce has identified it as a bug and created a known issue for it: https://success.salesforce.com/issues_view?id=a1p3A0000001C99QAE

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.