2

I'm trying to deploy a Bolt Template using ANT.

I am able to successfully deploy the template from one dev org into another new dev org.

But when I go to deploy into a different org, I run into this error when I run my task:

"contentassets/Screen_Shot_20170215_at_15130_PM.asset -- Error: You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary."

Where should I be looking to make adjustments?

1
  • I'm having the same problem, and finding it hard to see a solution in the documentation. Did you resolve this? Commented May 19, 2017 at 8:52

2 Answers 2

1

I've found that (in Summer '17, using API version 40.0), using only users who are able to deploy Content Asset inserts using the MetaData API and the ANT deploy tool are those with the "System Administration" profile.

It is not enough to have a user with a clone of System Administration, it must be the original System Administration profile.

2
  • Do you have reference for this?
    – Carl Ortiz
    Commented Nov 29, 2023 at 2:02
  • Sorry, I don't - nor to I have any recollection of writing this. Based on the phrase "I've found that" and my own behaviours I now presume that I found this through testing rather than documentation. There's been a lot of releases since (6 years ago!), so the behaviour may well have changed. Commented Nov 30, 2023 at 8:24
0

For this error, I have managed through trial and error to resolve this for my org, using a non System Administrator profile.

We had some files that would deploy ok, but others would get the error:

You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary.

And was able to determine it was throwing error only on the files for the Experience Cloud (aka Community)

Fix:

  1. If the files are for a Community aka Experience Cloud, the user deploying the changes MUST be a member of the community.
  2. Make sure that the profile/permission set grants permission to Access Libraries
  3. We already have enabled Salesforce Files > General Settings > Libraries in Salesforce Files (probably already enabled)

That what has allowed me to deploy, I tested by using the sf cli to deploy:

sf project deploy start --metadata-dir ./ --target-org <deploymentuser@domain> --dry-run

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .