1

I'm following this (Bulk Api) Trailhead, I have valid SessionId and when I try to authenticate I'm getting the following error:

I have created few records using the same SessionId and I know its a valid SessionId and I'm not sure what else is the issue here.

Error:

> exceptionCode: InvalidSessionId  
> exceptionMessage: Unable to find session id

Workbench:

enter image description here

  • It sounds like you may have gotten logged out of your Org while in Workbench. Otherwise, once you have a jobId, you can use the same jobId to add as many batches to it as you want but the url needs to be at /services/async/apiversion/job/jobId/batch. You can also query the status of the job or close the job if you have the jobid. – crmprogdev Feb 16 '17 at 15:00
  • I'm experiencing the same issue in Workbench. I haven't logged out of my org, but I still receive the same error message about the session ID. I attempted to log all the way out, and log in again, but to no avail. I even used 3 different browsers, but no luck. – Marypearl Parnell Mar 17 '17 at 16:08
  • Did this error resolved? I do get this error even after trying the way @suresh mentioned – SfdcBat Jul 26 '17 at 22:54
  • I'm not sure what I did but after couple of days I able to complete the trailhead, I'm thinking maybe you need to clear your cache and restart your computer and try? – Nick Kahn Jul 27 '17 at 15:24
  • one thing worth noting is that the URL actually needs to be 37 instead of v37... It's different from the services/data/ versioning for some reason – NSjonas Dec 2 '17 at 0:11
2

enter image description hereSession id should be in same row in workbench request headers. Please make sure login to developer session and try with this

X-SFDC-Session:00D36000000qbjo!ARoAQKiXWkLN9KMUcrhH8J11saoMuhArYs8JiYpo.WmGWCmPCNrDFS8riEl08mXy.mwC5XgexaZvnRHMSwb27VHIHxjcKSYu

Thanks Suresh

0

Instead of passing token, try passing running user sessionId in 'X-SFDC-Session'. It worked for me.

System.debug(UserInfo.getOrganizationId().substring(0, 15) + '***' + UserInfo.getSessionId().substring(15));

your sessionId is after the *** just to differentiate from OrgId to sessionId

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.