When I am trying to use Salesforce Lightning Design System in my vf page, I get error -

Unknown component apex:slds while including <apex:slds /> on my vf page.

Unrelated - I have also tried uploading the slds css as static resource and including it in page, it messes up the standard header. Please see screenshot below

enter image description here

  • You have asked two separate questions here. Try to stick to one question per question, please. – Adrian Larson Feb 16 '17 at 3:10
  • Sorry @AdrianLarson. As I was trying the second approach as a workaround I added it in this question. Your answer worked for me. For others - Please use apex: slds for slds in visualforce instead of linking slds.css manually – vishesh Feb 16 '17 at 3:14

Note that this component is only available starting with API Version 39.0. If you try to include it in API Version 38.0 and below, it will not be available.


I ran into this issue today as well. Until an updated version of the IDE is released that supports API version 39 you can create the page from the web UI and then sync it to your local copy in Eclipse. From that point on, you'll be able to save your changes without getting that error message.

  • Your IDE shouldn't prevent you from updating metadata to the latest version... maybe it won't set that version by default but you should be able to update it. – Adrian Larson Apr 12 '17 at 6:54
  • That's what I thought but even after editing the API version locally after creating it with API version 38 (max currently supported for new pages) save attempts failed from Eclipse. It's possible that it would have worked if I removed the unsupported tag when saving the change in API version and then added it back after but it definitely did not work with both changes simultaneously. – vscuorzo Apr 14 '17 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.