3

I'm currently developing on Spring'17 and I came across a problem regarding saving a Quote PDF using Salesforce standard functionalities.

On the Quote page I have a button to create PDFs which works fine and generates the quote on a PDFViewer (whether I'm running as Sys Admin or other user).

The problem happens when I click the "Save to Quote"/"Save and Email Quote" buttons and I'm not running as a Sys Admin. After I click them I get a message saying "Error saving PDF. Please try again".

I've already tried looking for someone having the same problem but only found this:

Community Users get 'Error saving PDF to quote please try again' when saving PDF Quote

I don't think that Lightning already existed by the time this issue was created. Nevertheless, it is said that the Summer 14 Patch solved it. Well, it didn't (at least for Lightning Experience)...

Also, on the Release Notes for Winter'17 (the release prior to the one I'm using) I get this:

Winter'17 release notes

Opportunity Email Quotes You can't email a quote directly from the PDF preview, the quote detail page, or next to the PDF in the Quote PDFs related list. Instead, create and save a quote PDF from Salesforce, and then download the PDF and email it using your local email app.

There is no mention to limitations on saving a PDF.

Has anyone else had the same problem and was able to solve it? Is it only available to System Admins (which doesn't make much sense)?

  • I am experiencing the same issue in a Non-Lightning environment at the moment. None of the proposed solutions in the success.salesforce-link you posted has worked for me. Have you found a solution yourself in the mean time? – MickS Feb 21 '17 at 13:36
  • hey @MickS, I've solved my issue and posted an answer. hope you can solve it this way too! – LuisF Feb 22 '17 at 14:25
2

Ok, so yesterday I found out how to solve this.

I don't know if it is on purpose or not but I was impersonating non-admin users via my System Admin user, by going to Setup > Users > Login

If, on the other hand, I actually login as the user I want to test by going to the login screen and input my username and password, the whole process works fine. It's what we've been calling here on our team "the Salesforce Way"

-1

I think we found a solution. It seems that the User must have a profile or permission that enables Chatter. Apparently the PDF is generated using Chatter. So, if you activate Chatter for the Profile or assign through a Permissionset, it should work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.