0

Users started receiving limit exceeded error while trying to save a CASE from this afternoon and it appears to be sporadic (it gets saved after multiple attempts) but happening 80% of the times. In debug logs, it shows "EXCEPTION_THROWN|[629]|System.DmlException: Upsert failed. First exception on row 0; first error: LIMIT_EXCEEDED, limit exceeded: []" but not sure what went wrong. I have made sure that there no SOQL limt exceptions in the logs and also, nothing was changed/deployed in past one week (neither configuration nor code changes). Any thoughts?

  • 1
    Without looking at the code, it would be impossible to identify what went wrong. – Avinash Feb 13 '17 at 22:35
  • Also, it looks like a DML limit exception, not SOQL. – Avinash Feb 13 '17 at 22:41
  • 1
    Quite possibly being caused by accumulated DMLs and not just the single save being attempted. Take a look into the logs and find out where your limits are being consumed within this users transaction. – TSmith Feb 13 '17 at 23:01
  • Right, I have checked for accumulated DMLs (in logs till the exception point), and it doesn't come closer. Also, I am curious, why it started mid of the day which has been up and running for past 6 months. – srikanth pasupuleti Feb 13 '17 at 23:22
  • this is last LIMIT USAGE just above the exception. Number of SOQL queries: 27 out of 100 Number of query rows: 38 out of 50000 Number of SOSL queries: 0 out of 20 Number of DML statements: 2 out of 150 Number of DML rows: 2 out of 10000 Maximum CPU time: 386 out of 10000 Maximum heap size: 0 out of 6000000 Number of callouts: 0 out of 100 Number of Email Invocations: 0 out of 10 Number of future calls: 0 out of 50 Number of queueable jobs added to the queue: 0 out of 50 Number of Mobile Apex push calls: 0 out of 10 – srikanth pasupuleti Feb 13 '17 at 23:25
2

I figured it out.. we have Omni channel enabled and case count in the the queue has reached the limit.

| improve this answer | |
  • You may want to mark this as best answer and close this thread. – Santanu Halder Feb 14 '17 at 4:48
  • I think I need to wait for 48 hours to do so. – srikanth pasupuleti Feb 14 '17 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.