4

I woke up the morning after the Spring '17 release and my Koa community template is permanently in mobile mode. I removed all of my custom CSS and everything is still stuck in mobile. Has anyone seen this?

I decided to try to create a new community in a new sandbox and I'm receiving the error Login is required to access this salesforce.com URL. Please contact your administrator if you feel this is an error.

I tried debugging the error, but no logs are produced. I made sure my sys admin profile had all required permissions, and that all of the community page/controllers are accessible. Still no luck. Any advice?

Edit: If you're seeing the error Login is required to access the salesforce.com URL try renaming the community. Either the issue magically resolved itself, or it was throwing an error because the community name (not url) already existed in the sandbox.

Edit 2: After doing some digging it seems that salesforce is trying to force my page through some sort of "login" template. I inspected the page and found the container wrapped in the salesforceIdentityLoginBody class, replacing the actual login page with our index. Our community is anonymous and doesn't require login.

1

SF support confirmed this was a problem with their Spring 17 release. If you're facing this problem contact support. There is no way to fix this yourself without creating a whole new community.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.