1

This package includes a Record Type on the Task object. I am able to uninstall if I do it right after installation, but if I enable the use of the packaged Record Type on the user profiles, I am no longer able to uninstall:

Component Type   Name              Problem
Record Type      [recordtype name] This installed component is referenced by a locally
                                   created component     

There is no link to what componenent it's talking about, but I'm assuming it's all of the profiles that were enabled to use this record type. However, I have removed this recordtype from the enabled list for all Profiles, and it is deactivated for the org. I tried removing it from the Profile XML directly through the Force.com IDE, but am not able to make it stick. At this point, I don't know what else to try. I have to think this has been encountered before, though. How do managed packages generally deal with record types?

  • I actually tried that; I created a recordtype, made it the only available recordtype for all profiles, and tried uninstalling, but received the same error. – Jeremy Nottingham Oct 9 '12 at 14:18
1

Have you checked out the Known Issues list. At this point are you still in a development org?

Is this the first time you've encountered this after including this component in you package?

  • I am still in a dev org. I have looked through Known Issues, but don't see anything that matches my issue. Current workaround is to make a new dev org and install there. Obviously, I'm concerned about installing into a production org and not being able to uninstall. – Jeremy Nottingham Sep 24 '12 at 17:05
  • Hmmm...have you checked the page-layouts for the 'Task' object to see if it got added there to a picklist of available record types – jordan.baucke Sep 24 '12 at 17:12
1

Is the record type on the Task object the only Task record type? You might need to add your own custom Task record type, use this as the default for all Profiles, and then deactivate the installed Task record type and try uninstalling.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.