0

I have exposed a visualforce page to non-salesforce users using sites. This site is accessible using http and no login is required. How can I make this site accessible using https ?

2

To require secure connections, under "Setup", go to the site you would like to be accessible through https, press "Edit", then select the "Require Secure Connections (HTTPS)" checkbox.

enter image description here

However, regardless of this setting, the site can be accessed via https.

  • They should be available even without this option selected, no? – Adrian Larson Feb 7 '17 at 23:40
  • I believe you're correct there. Edited to reflect this. – SFDC Neuf Feb 7 '17 at 23:41
  • When I access it with https without the option selected, i get a message "your connection is not secure" when I say proceed anyway, it takes me back to http url – apn Feb 7 '17 at 23:46
  • 1
    What browser are you using? I think that's browser behavior. I'm not seeing that with Chrome. – SFDC Neuf Feb 7 '17 at 23:55
  • @apn Are you using custom domain? – Saroj Bera Feb 8 '17 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.