0

We have a managed package on AppExchange.
After installing that package there is some configuration to do on a 3rd party site (Middleware).
The configuration page can be accessed via a configuration link.
That link is under the Salesforce menu installed packages --> configure.
(If you click the link a new page opens)
Everything works fine while in Salesforce Classic.

But when clicking that link in Salesforce Lightning the newly opened page is stuck at the integration servlet and the page remains all-white. If you take a look at the console it states:

The target origin provided ('https://xxxx.lightning.force.com') does not match the recipient window's origin ('https://xxxx.salesforce.com').

The URL which is generated by Salesforce (lid, eid, linkToken are fake):

https://xxxx.salesforce.com/servlet/servlet.Integration?lid=000000000000000&eid=00000000000000&ic=1&isdtp=p1&linkToken=r0os0w0e0l0l0s0t0y0l0e

There the isdtp=1 parameter came to my eyes. For what I have read that parameter is for detecting if you are accessing Salesforce via Lightning.
If I copy that very same link and remove the isdtp=1 everything works fine and the page is loading.
But I guess I have no influence on that link programmatically.

So my question is simply what can we do to get our package configuration link working in Salesforce Lightning?
Any help is highly appreciated. And please let me know if you need further information.

1
  • How did you build the page so it appeared in the Configure Custom Link picklist? I can't find the info about this. – Andrii Muzychuk 7 hours ago
0

Meanwhile, Salesforce fixed this bug.
https://success.salesforce.com/issues_view?id=a1p3A000000ezaQQAQ

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.