1

Can any one suggest how to fix this error. When I am trying to access a VF page from SF1 App, upon clicking the button following error is encountered.

"Can't view this page...don't have permission / isn't supported on mobile..."

Any help is greatly appreciated.

Thanks

3
  • Make sure you have Available for Salesforce mobile apps and Lightning Pages checked for the visualforce page. Jan 31, 2017 at 10:45
  • Its been enabled already!!
    – venky
    Jan 31, 2017 at 10:46
  • Is this issue is fixed? If so can you tell me the solution?
    – SFDC
    Sep 3, 2018 at 7:27

2 Answers 2

0

This is a known issue as reported by Salesforce. You can try the workaround explained in the article.

Extracts from the link.

Summary Customers may notice an error when trying to open an inline Visualforce page from the standard record detail page (or mobile card) while in a Community. This same inline Visualforce page will open as expected when in the standard Production environment.

In the Community, a preview of the Visualforce page is shown on the record detail page (i.e. mobile card), but when a user taps to open this page they may see the following error:

"You can't view this page, either because you don't have permission or because the page isn't supported on mobile devices."

Repro 1. Launch Salesforce1. 2. Open the navigation menu and switch into a Community. 3. Open any record with an inline (embedded) Visualforce page. 4. Tap on the Visualforce page preview to open the full page.

Users sees error message: "You cannot view this page, either because you don't have permission or because the page isn't supported on mobile devices."

Workaround A text link pointing to the Visualforce page or a Detail Page Button that uses the Visualforce page as the source should open the page as expected.

Don't utilize mobile cards for VF pages needing to be interfaced via users.

3
  • Currently, I have implemented an Action on the object, upon clicking Action Visualforce page should display. However the issue is not resolved.
    – venky
    Jan 31, 2017 at 11:50
  • Is this issue is fixed? If so can you tell me the solution?
    – SFDC
    Sep 3, 2018 at 7:27
  • You can check the link, it is showing as fixed.
    – Saroj Bera
    Sep 3, 2018 at 8:20
0

As this works in the browser and not in the app, maybe this is due to the redirecting to the page not working in the app. You can try using this JS code in the VF page to redirect in browser or app.

<apex:page standardController="Account" sidebar="true" showHeader="true" standardStylesheets="true" id="vfpage">
<script type="text/javascript">
var link = document.getElementById("vfpage").action();
if( (typeof sforce != 'undefined') && (sforce != null) ) {
    sforce.one.navigateToURL(link);
} else {
    window.location.href = link;
}
</script>
</apex:page>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .