36

Since yesterday my dev console is jumpy when I scroll with the mouse wheel.

I use windows on chrome at 80% zoom default. Putting it back to 100% zoom does not fix the problem.

I only have this problem in the Salesforce Developer Console (and by extension Salesforce) and does not occur on any other websites.

Does anyone knows why is this happening? Thank you!

RESPONSE FROM SALESFORCE SUPPORT: We have reached out to R & D about this issue and they are actively working on it. As of now, a possible work around for this issue is to use Firefox as this seems to be happening only in chrome. Also, we currently do not have an ETA on the fix or a Known issue link. But in the near future, if you want an update regarding the issue, you can log a case with us by referring the investigation:- "W-3697984"

  • 2
    I love Dev Console! Been using it for 80% of development in recent months. However, I recently started experiencing this scroll jumping behavior on Chrome v56 for Mac. The experience got so unbearable that I've switched to Firefox to continue using Dev Console. Hope someone at SFDC figures out the cause! – dlog Feb 2 '17 at 21:22
  • 1
    The known issue has been created: success.salesforce.com/issues_view?id=a1p3A0000008gTYQAY – Kasper Mar 6 '17 at 11:25
  • 13
    enter chrome://flags into the address bar then search for the setting: Scroll Anchoring, and disable it. Worked for me. – Chris Mullins Mar 15 '17 at 14:45
  • 3
    @ChrisMullins would you mind still making that into an answer ? I've reopened the question. – Samuel De Rycke Mar 28 '17 at 6:24
  • 1
    Someone else made an answer for it, with images, looks good to me. You can go ahead and accept that. Not in it for the points. – Chris Mullins Mar 29 '17 at 14:47
26

Go to chrome://flags/#enable-scroll-anchoring the highlighted option is Scroll Anchoring disable it.

Now you will see the message "Your changes will take effect the next time you relaunch Google Chrome." in the bottom with a button RELAUNCH NOW, When you hit this button chrome will relaunch. So first save all your work and then hit this button.

Disable Scroll Anchoring in chrome

Credit: @ChrisMullins

  • 2
    I can confirm that this has fixed the issue for me. – Mossi Apr 11 '17 at 23:55
  • 1
    This also works for the Opera browser with the following opera:flags#enable-scroll-anchoring – Nick Cook Apr 12 '17 at 1:53
  • 1
    Chrome v68 - problem is back and now they have "Scroll Anchor Serialization" - no setting prevents the jumpy behavior. Ugh. – Ken Aug 10 '18 at 19:03
12

There is a Known Issue for this - Developer Console jumping when using mouse scroll

Summary
When working in any piece of code in the Developer Console (apex class, lightning component, trigger and so on) if the user start scrolling down through the content of the piece of code using a mouse wheel, the screen starts scrolling, but then the view intermittently jumps in the opposite direction a few lines.

The current indication is that this is resolved by updating Chrome to v57. However, I've seen reports that this is still an issue even after updating to the latest version of Chrome.

There is a proposed workaround by Chris Mullins (which will hopefully be posted as a separate answer soon).

UPDATE: The issue is back in review status as the problem is still occurring for some users with v57 of Chrome. Since it is in review you can indicate that it is affecting you.

  • Yeah, I'm running Chrome 58 and still notice this issue. EDIT - just read the comments on the OP. Trying out the fix there... – Brian Mansfield Mar 28 '17 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.