0

ISNULL() for currency fields is not returning true even though the value is null. I've tried != null and its still the same. Well the original formula is quite complex an i've narrowed it down to the below just for testing purpose. I've tried testing with other null currency values and it still seems to be not working.

IF(ISNULL(field__c), 1, 0)
6
  • Please share the code you try !
    – SF_user
    Jan 26, 2017 at 15:35
  • ISNULL() has been deprecated for a while. Salesforce suggests using ISBLANK() instead, which is basically the same thing, but supports text fields as well.
    – Derek F
    Jan 26, 2017 at 15:55
  • Also, in your formula, do you have it set to treat blanks as zeroes, or as blanks?
    – Derek F
    Jan 26, 2017 at 15:56
  • Don't be mistaken, simply changing your formula to use ISBLANK() won't fix anything, it's simply best practice.
    – Derek F
    Jan 26, 2017 at 15:58
  • Yes, It didn't work either. I've tried ISBLANK(field__c, 1, field__c) and it returned 0. The field is definitely null but the formula seems to be treating it as 0 rather.
    – Pratik
    Jan 26, 2017 at 16:02

1 Answer 1

1

Sounds like your formula is set to treat blanks (nulls) as zeroes rather than as blanks.

If your formula is treating blanks as zeroes, then when your formula is being evaluated, it looks like this

IF(ISBLANK(0), 1, 0).

As 0 is not equal to null, your formula is taking the else part of the IF() formula, resulting in 0.

Change that setting so that your formula treats blanks as blanks, and your formula should work (and once more, ISNULL() is deprecated, and best practice is to use ISBLANK() instead).

1
  • Didn't notice the checkbox at all. I'm am a dev trying to fill in for an admin. Good to know new things. Thanks for your assistance.
    – Pratik
    Jan 26, 2017 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.