0

Just now I installed Force.com plugin for Eclipse and I see limited number of components like Classes, Triggers, Pages & Static Resources. I removed and installed twice but not sure what I am missing. The screenshots below shows that I don't get option to choose Metadata components.

no options to pick Metadata components

Project Contents

2

You need to modify your package.xml manifest file. You can add any components you want there. Then refresh your src folder.

You can see how to include most types in your manifest by looking in the Metadata API Developer Guide. For example, see CustomLabels:

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <fullName>MyPkg</fullName>
    <types>
      <members>*</members>
      <name>CustomLabels</name>
    </types>
    <version>39.0</version>
</Package>

Of course you can also include them through the UI via the Add/Remove Metadata Components option, but you still need to refresh your folder from the server.

| improve this answer | |
  • I really like using to this. Add/Remove Metadata Components option in eclipse is super slow! – Raul Jan 23 '17 at 19:39
  • Incredibly so. It got to a point where it would even crash my IDE and even computer sometimes. – Adrian Larson Jan 23 '17 at 19:40
1

Right Click on "Test" <Project Name> in 2nd screenshot > Force.com > Add/ Remove Metadata components..

| improve this answer | |
  • you could have added this post as a comment instead of an answer. – Raul Jan 23 '17 at 19:38
  • What i mentioned is not the straight forward and simple solution ?? Anyway, up to you if u feel this as not answer. Thanks :) – sf_user Jan 23 '17 at 20:24
  • I think it's fine as an answer, honestly. Not sure why it's being received so harshly. – Adrian Larson Jan 23 '17 at 21:04
  • Well our Org is pretty light and this solution is what exactly I was looking for as I am very new to Force.com IDE. It's working fast for me. But the other answer is a step ahead and explains even more, so I chose that as Best Answer. Thanks everyone. !! – Amulya Jan 23 '17 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.