1

I can see and use the global header to get to my community, so the permissions are set correctly.

However, the header is not shown when in the community. All the guides I can find seem to indicate that if I can see it in my org normally, I should be able to in the community too.

Is there something else I need to do?

Eric

Adding images to clarify

While use (SF Admin) is in SF

enter image description here

When Admin clicks on the "My Account" community the header is missing and no way to really get back to SF

enter image description here

3
  • Are you logged in as internal user and after switching the community from internal to external, you don't see any global header?
    – Raul
    Jan 23, 2017 at 1:52
  • Logged in as internal user, then switch to community via the global header shown in my salesforce org. Not sure if that switches the community from internal to external?
    – nicstella
    Jan 23, 2017 at 2:01
  • 2
    A screenshot would be helpful.
    – Raul
    Jan 23, 2017 at 7:50

1 Answer 1

0

The cause of this issue is that your internal users aren't members of your Community and consequently are only seeing the Company Name.

See Access Your Communities from Salesforce in the Help.

  • The dropdown shows all the active communities that you’re a member of.

  • If you have the “Create and Set Up Communities” permission, you also see communities in preview that you’re a member of.

  • Internal users who aren’t members of any community only see the company name.

  • External users see the dropdown menu only if they belong to more than one active community.

  • If an external user who is only a member of one active community is given the URL for a community in preview, they don’t see the dropdown menu in the community.

5
  • The System admin is a member of the community and that is the profile I am using. We also do not even see the company name. The header is just not there at all while in the community. While in SF the header with the community option is present. I added images to the question to make it more clear. Also, not this is all done while logged in as myself, the system admin. System admin profile is part of the community as is the show global header permission set
    – Eric
    Apr 24, 2017 at 14:01
  • I know there's an issue with the Global Header not appearing in Lightning Orgs, but am not aware of any issues with it not appearing in the actual Community (Lightning or otherwise). Is there a particular template you're using? I see the question is tagged employee-community, does that tag also apply to your situation Eric?
    – crmprogdev
    Apr 24, 2017 at 20:44
  • napili. Sry was piggybacking off other question and did not think about the tags. Doh
    – Eric
    Apr 24, 2017 at 20:45
  • Is the community active?
    – crmprogdev
    Apr 24, 2017 at 20:48
  • Yup and lightning. And new org within last month if it matters
    – Eric
    Apr 24, 2017 at 20:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .