1

We're trying to implement an external Auth provider for a community. It is the only auth provider that is enabled on the community, and it seems to be correctly configured, since it works as expected when using the *.force.com domain.

When accessing the community via the custom domain, clicking Login on the community page takes you to the community login page, and does not redirect you to the provider.

When accessing the community via the default force.com subdomain, clicking Login on the community page automatically redirects you to the auth provider login page (if you're not already logged in with that provider), or authenticates you and redirects you back to the community with a profile (if you are logged in on that provider).

Can anyone shed any light on why it works with the default domain but not the custom domain?

Thanks

  • What do you mean by clicking Login takes you to the community login page? What happens when you hit the community URL? – Saroj Bera Jan 20 '17 at 6:18
  • @SarojBera I mean clicking the login link within the community page. I'll clarify in the question. – mwotton Jan 20 '17 at 6:19
  • In standard community login page, you can add the authentication providers where a user can click on the Auth Provides link and login to the community. Can you please post a screenshot of the browser for Community landing page? – Saroj Bera Jan 20 '17 at 6:27
0

This could be due to

1) Mandatory redirect param not set properly

Site Primary Custom URL 

"This is only available on the root path for Force.com and Communities sites"

2) Ensure the parameter /services/auth/sso is pointing to your Auth Provider URL

3) You might want to check the redirection in Chrome/ any other network tool to capture the HTTP requests. Another reason could be SSL not supported.

| improve this answer | |
  • Where do I see those parameters in points 1& 2? – mwotton Jan 23 '17 at 1:32
  • #1 - Where you setup your custom domain #2 - This is part of your auth provider settings – Gaurav Kheterpal Jan 23 '17 at 4:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.