1

I'm getting killed by this bug.

I can log into my developer account and my sandbox account from Force IDE.

When I try to log into the production account I get the following error:

Unable to connect to hostname 'login.salesforce.com':

Invalid username, password, security token; or user locked out.

Please verify and/or change your credentials.

picture of auth screen in Force IDE XXXXX'd out my username for security reasons, but it's my valid username in prod.

I'm able to use these same credentials to access the salesforce.com dashboard and the Force.com REST API in production.

NOTE: Another account on the same domain works. So potentially locked out from Force IDE? Any tips on finding this setting in the salesforce dashboard?

  • Are you specifying a proper security token? – Adrian Larson Jan 19 '17 at 18:19
  • Security Token should be provided with password or white list the IP – Ashwani Jan 19 '17 at 18:20
  • Yes - the security token is specified. The same security token is working with the REST API access. I have tried appending the security token to the password as well. – Charlie Youakim Jan 19 '17 at 18:23
  • 1
    Did you check your login history to see if there were any failed attempts from the IDE? You can check under your user detail screen. – sfdcfox Jan 19 '17 at 18:43
  • 1
    then... user is locked. – Ashwani Jan 19 '17 at 18:46
1

Assuming all values are correct then it is possible the profile has Login IP Ranges defined:

  1. Login to production via the UI.
  2. Goto the profile associated with your user
  3. Look at the "Login IP Ranges" related list.

enter image description here

If it is populated your security token cannot be used (you will also notice the reset security token option is not available to your user) so remove it from your IDE login. You will have to be at an IP listed in the login ip ranges list.

Otherwise, your values are most likely not correct as you think or the user is locked out.

Additional troubleshooting can be found under your user record and the Login History related list.

| improve this answer | |
0

The user account was locked. I found this in the settings. I'm not sure why the account was allowed access via other methods.

Thank you for your help. We reset the password and it's working.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.