0

I've created an unmanaged package that consists of:

  • several fields for a Lead object,
  • and one Visualforce page (Pages_Visited)

During the installation of this package I get the following error: enter image description here

The mentioned field is certainly present in the package: enter image description here

And the Pages_Visited Visualforce page works perfectly fine on my Developer org. It references the field like this:

<span id="gaconnector_pages_visited_list">{!lead.zuevsoftware__Pages_visited__c}</span>

I've tried installing this package on two orgs, one of them completely clean (no custom fields, no Apex triggers, nothing custom). And both times I received the same error.

What could be causing this problem?

  • Might be due to namespace if its a managed package. – RCS Jan 18 '17 at 11:40
  • @RCS it's a managed package – Sergey Jan 18 '17 at 13:24
  • 1
    Just remove the namespace before custom field and try – RCS Jan 18 '17 at 13:28
3

It seems to be namespace issue: Try replacing to below syntax:

<span id="gaconnector_pages_visited_list"><apex:outputField value="{!lead.Pages_visited__c}" /> </span>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.