2

I am running into the same error as i have seen on other forums but all the fixes are not solving my issue.

The process starts when a contract is created or edited.

Then i check to see if a field on the contact of the contract has a particular value. The formula is:

[pba__Offer__c].pba__Contact__c.Retail_Lead__c="Yes"

However on running the process i get the following common error.

The flow failed to access the value for myVariable_current.pba__Contact__c.Retail_Lead__c because it hasn't been set or assigned.

A common fix was to handle that either the contact may be null or the field i am accessing may be null, so i have included the checks to see if both a null as follows:

AND(NOT(ISNULL([pba__Offer__c].pba__Contact__c)),
NOT(ISNULL([pba__Offer__c].pba__Contact__c.Retail_Lead__c)),
[pba__Offer__c].pba__Contact__c.Retail_Lead__c="Yes")

This still did not fix it.

I also tried to use a condition before my main check to validate if any of the fields were null, however the error was still there.

The only thing i can think might be the issue is that the "Retail Lead" field is a formula, should that cause any problem?

enter image description here

I have tried to use but it has the same effect:

|FLOW_ELEMENT_ERROR|The flow failed to access the value for myVariable_current.pba__Contact__r.Retail_Lead__c because it hasn't been set or assigned.|

I am hoping it should look something like this

enter image description here

Please note i am using PropertyBase which is basically sales force with custom objects.

  • 1
    Hi. Did you try? [pba__Offer__c].pba__Contact__r.Retail_Lead__c="Yes" – Martin Lezer Jan 16 '17 at 7:47
  • Did you get this information from email? – Tushar Sharma Jan 16 '17 at 9:37
  • Can you share screenshot of criteria section – Reshma Jan 16 '17 at 9:57
  • I think the problem is that the formula field will not hold a value when accessed by the flow. – Dave Humm Jan 17 '17 at 0:33
  • 2
    I have created formula field on the Contract object (main object) pulling the value from the Contact. PB seems to do ok when a formula field on the Main object is null but not when a relationship field/formula is null. So try creating a formula field on Contract (main) to pull the value from the Contact (Related) and use that formula field in the PB. Sucks but it worked for me before (although it was a few release ago when I tried it) – Eric Jan 17 '17 at 1:09
0

Thanks Eric, that solution has worked for me. Seems the problem was accessing a formula field in another object. This unfortunately creates duplication of fields in the objects, but at least it is working. Thanks for the help.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.