3

This is a problem I've dealt with randomly for many years now.

At my new company, our Full sandbox has what I like to call a "caching" issue. I know no other way to describe it.

Every morning, I am the first at work and the first in our Sandbox (frequently the only one all day).

When simply viewing, or inserting or editing, a record into the Full sandbox for the FIRST time for EACH object, it takes 15-60 seconds for the appearahce, or save, to happen (assuming no Apex or other intervention - then it could be up to 2 minutes).

Even visiting the Apex dev pgaes takes 15-45 seconds the first time "per day" (though really it's "per several hours").

AFTER that first touch inside any given object, that object THEN works JUST AS IT SHOULD, speed-wise.... until you stop touching it for several hours. Then it happens again. This equates to "caching" putting it simplistically. "Priming the pump" as some of my users put it.

  1. Anyone experience the same thing? This is the second Sandbox I've had this happen in officially. Have heard it from another Admin I used to work with also.

  2. Anyone know the right "keywords" to get SF to NOT spend weeks in a Ticket discussing this, deflecting it to a code issue, plugin issue, user issue, etc, so that they can flip the proverbial switch to FIX IT?

The person in charge of our Org prior to me (a contractor) spent 3 months in an SF ticket, chasing down ghosts involving:

  • Rootstock
  • Financiah Force
  • SF Country/State Picklists

...only to have (me) back at square one.


UPDATE 2017-01-16: Sent log of access to SF Support as they state they will check my audit trail and see why the delays are happening. Attaching log here as a reference with Org-identifying info redacted.

enter image description here


UPDATE 2017-03-13:

  • Salesforce has isolated the problem to their "precompile" feature (which is not firing when it should to keep Apex fresh all over the Org - not tied to any managed package - it happens if you visit the Apex Classes page, it happens when visiting a record, creating a record, etc, first time every 'few hours'
  • I tested in the Production org (where Sandbox originated from) and it has teh SAME PROBLEM (and is just as slow, which is bizarre considering Production typically has "more resources" and you'd at least expect it to do it "faster" - it does not)
  • Salesforce has abandoned the situation after almost six months across two cases. Abandon Ship
  • I see this all the time. I would say that many orgs with FF installed have this issue. Additionally it is not isolated to FF issues. Org caches are invalidated after specific actions / timeframes and they need to be rebuilt. You are not the only one. Unfortunately, I do not believe it is something that will / can be resolved easily or soon. The only way would be multiple high value customers submitting tickets and showing SF that it affects their business. The fact that it is usually on the "First In" to be affected reduces the urgency.... – Eric Jan 16 '17 at 16:07
  • There was a breakout session at DF 16 that talked about this...I wish I could find the video / remember the session.... – Eric Jan 16 '17 at 16:08
3

I had a similar problem with Accounts that sounds very similar to what you're getting now.

Every morning an Account record would not load. Typically, it would time out until you refreshed the record anywhere between 3 or 4 to dozens of times. Then, it would work fine. The whole object, not just that record.

You're right in that it's a caching issue, but the solution for us was that it wasn't caching in Salesforce, but the browser.

Depending on what browser (we use Chrome) you're using, deleteing your:

  • Browsing history
  • Download history
  • Cookies and other site and plug-in data
  • Cached images and files
  • Passwords
  • Autofill form data
  • Hosted app data

And selecting:

Obliterate the following items from: the beginning of time

Worked for us. There were a few people who had this problem, and clearing browsing data fixed it.

Hopefully this simple fix will work for you as it did for us, it sounds very similar to problems we had, so it may be worth a shot.

As it happens, we contacted Support about this thinking it was Salesforce itself, and it was the rep himself that suggested starting here.

  • Well... I can try this, though it seems quite bizarre to me that every browser-brand on every user's computer is doing it. (sigh) Also, that when any ONE person primes the pump so to speak, the rest of the users don't have the problem. I'll see what happens. I would also argue that since over THREE MONTHS was wasted between support Tier 1, then 2, then 3 along with the then-Admin, this not being brought up.... yeah. Whatever. Crossing fingers. – AMM Jan 12 '17 at 18:09
  • @AMM This just sounds so similar to a problem we had, it's worth a shot. Seems like you've tried every other avenue as well. It was odd that several people had a problem, although it was only on Accounts. When everyone cleared the cache, we we're golden. Yet, clearing the cache somehow cured it. I wish I could explain to you the who/how/whys of it. – Dan Jones Jan 12 '17 at 20:02
  • As I unfortunately expected, the clearing of (literally) everything did not help. I was able, however, to cause enough of a stir at SF with a "threatening" support ticket that they contacted me later that day, and we had a phone call Friday last week - and they agreed to review audit logs if I would supply them with specific records attempting to be accessed "first thing" in the day with date/times, then subsequent records in the same object, blah blah. They now have that log and are reviewing to see"whatever they find" Yay? – AMM Jan 16 '17 at 15:32
  • @AMM Sorry this didn't work for you. I know I was sceptical when they asked me to do that, but as it happened it did work in my case. Sounds like you're having a nightmare with it, but hopefully it'll get fixed soon. At this rate maybe it'll get to the point that Mr. Benioff himself is sorting it! – Dan Jones Jan 16 '17 at 15:37
  • 1
    Yep. Appreciate the input either way. I'm just glad a "frustrated threat" got their attention immediately. I was pretty sure they'd laugh at it, but even if they did... they responded. ;-) – AMM Jan 16 '17 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.